Blog

Archive for October, 2017

Fanvil Click to Dial

I have been playing around with this for a while and i have managed to get this going. This is really just notes for me but it may have you too.

Install Chrome C2D URL

Then under options fill out the IP address and username and password (admin and admin by default)

Dial:  http://admin:admin@$phoneAddress/cgi-bin/ConfigManApp.com?key=HEADSET;key=$number;ENTER

add key=HEADSET; to the beginning if you always want it to pick up the headset.

add key=SPEAKER; to the beginning if you always want it to pick up on Speaker.

Hangup:  http://admin:admin@$phoneAddress/cgi-bin/ConfigManApp.com?key=RELEASE

I’m working on this plugin to clean it up a bit and remove the status as its not needed for this phone.

Posted in: Blog, Technical

Leave a Comment (1) →

Add Exchange mail box disabling the auto mapping in outlook.

Outlook 2010 has this cool feature that auto maps the mailboxes that you have full access to. But some times you want to have access to everyone email but not have them taking up space on your outlook.

 

This command will add full access for admin@example.com to everyone but the Admin mail box. 

Get-Mailbox -ResultSize unlimited -Filter {(RecipientTypeDetails -eq 'UserMailbox') -and (Alias -ne 'Admin')} | Add-MailboxPermission -User admin@example.com -AccessRights fullaccess -InheritanceType all -AutoMapping:$false
And This command will add admin@example.com to the accounts mailbox.
Add-MailboxPermission -Identity Accounts -User admin@example.com -AccessRight FullAccess -InheritanceType All -Automapping $false

Posted in: Blog, Technical

Leave a Comment (0) →

LibreNMS Freeswitch agent-local

I had a few issues getting the freeswitch agent-local to work. In the end the fix was simple. The FSCLI path was wrong in the /opt/librenms-agent/agent-local/freeswitch file. I found the correct path by running find / -name fs_cli and editing the FSCLI=/usr/bin/fs_cli to be correct.

 

Update: If you would like the Apache Status to work add the following to your apache config  /etc/httpd/conf/httpd.conf
ExtendedStatus On
<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from localhost 127.0.0.1
</Location>

You can check by running /opt/librenms-agent/agent-local/apache

 

Posted in: Blog, Technical

Leave a Comment (0) →

Cisco router NBN HFC

HI

 

I had a issue when a customer was moved over to a HFC NBN connection. It seems that you can not just use a PPPOE dialer you also have to have a vlan 100 tag on the FastEthernet port.

 

Here is the config if it saves some one some time.

config t

vlan 100
name NBN

interface FastEthernet3 –The port the NBN modem is plugged in to
description — Ethernet WAN —
switchport mode trunk
no ip address

interface Vlan100
description — WAN —
no ip address
ip nat outside
ip virtual-reassembly in
ip tcp adjust-mss 1452

pppoe enable group global
pppoe-client dial-pool-number 1

interface Dialer1
description — NBN HFC —
mtu 1492
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer string “*99#”
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxx
ppp chap password xxx
ppp ipcp dns request accept
no cdp enable

To Connect to a IPoE like in FTTP

On the interface you have connected to the NTD.

interface GigabitEthernet0/0
ip address dhcp //this is for IPoE
ip access-group WAN_IN in //this is the inbound ACL
ip nat outside // if you are doing NAT (most likely)
duplex auto
speed auto
no cdp enable
!

These are the basics and should get you connected, you’ll need the NAT and routing added on top of this to serve your LAN

ip nat inside source list 101 interface GigabitEthernet0/0 overload   //basic NAT using access list 101
ip route 0.0.0.0 0.0.0.0 dhcp  //default route to the IP assigned by IPoE
!
access-list 101 permit ip 192.168.1.0 0.255.255.255 any  //Allow internal LAN for NAT

Again very basic and open setup, you will want much more for security.

 

This was tested on a 887VA running flash:c880data-universalk9-mz.151-4.M9.bin

Posted in: Blog, Technical

Leave a Comment (0) →